Jump to content
JavaScript is currently disabled in your browser. In order to watch videos JavaScript needs to be enabled. Here are the instructions how to enable JavaScript in your web browser.
Your browser is out of date and not supported. Click here to download the latest version of Internet Explorer.
Sign in to follow this  

Maps gone from my Bushnell GPS download

Recommended Posts

Hi, I have a Bushnell, BackTrack HuntTrack that I use for hiking. I download my hikes to the computer and it uses Google Maps. Up until a week or two ago it worked just fine. Now all of a sudden all the download will show is the tracks of the hike without map or satellite image. I contacted Bushnell and they sent me to Registria which handles maps and they gave me some help, which unfortunately didn't work. I've tried everything I could think of to correct my problem, but again, nothing. (restoring to earlier date and redownloading the computer app)

I have free Avast anti-virus and recently got the computer clean up and I am wondering if somehow that messed me up for my maps downloads.

Any suggestions?





Share this post

Link to post
Share on other sites
Sign in to follow this  

Want to join the conversation? Become a Kim's Club member Sign in